Portail · Index · FAQ · Rechercher · Membres · Groupes  · S’enregistrer  · Profil · P.M. · Connexion
Tribulation autour d'un TSX17

 
Poster un nouveau sujet   Répondre au sujet    Maintenance Industrielle Index du Forum -> Automatisme -> Télémécanique
Sujet précédent :: Sujet suivant  

Auteur Message
dimdim37
NOUVEAU MEMBRE
NOUVEAU MEMBRE

Hors ligne

Inscrit le: 06 Jan 2012
Messages: 2
France Technicien maintenance Masculin

MessagePosté le: 06/01/2012, 17:57    Sujet du message: Tribulation autour d'un TSX17 Répondre en citant

Bonjour à tous !

Voilà mon gros problème :

Je m'occupe depuis peu d'un outillage datant de 1993 et commandé par un automate TELEMECANIQUE TSX17 (TSX 23428).
Jusque là, pas de problème, mais comme l'outillage est vieillissant et que j'ai découvert que je ne disposais pas d'interface de dialogue avec l'automate et que personne ne possédé le programme d'origine alors j'ai profité d'un arrêt annuel de l'outillage pour prendre la référence des mémoires RAM de l'automate. Sauf qu'à la reprise du début d'année, plus aucune sortie automate active, bien sûr j'ai vérifié la présence des alimentations de l'automate, de la partie puissance et le bon fonctionnement des entrées... Tout cela est conforme.

Alors désespéré de voir mon diagnostic ne pas avancer, je commence à avoir peur d'avoir "scratché" le programme. Je ne me suis pas posé de question au moment de retirer la RAM puisque pour moi, la seule façon d'effacer son contenu était soit la connexion et la commande via PL7-2 ou alors le passage des EPROM à la lampe à UV (Aucun jumper présent sur la cartouche RAM pour un éventuel reset).

Voilà, 72h après le début du problème, je commence vraiment à avoir de gros problème de sommeil, je vous serez très reconnaissant de me rassurer en confirmant mon hypothèse à savoir que le retrait des 2 RAMs pendant 15 jours et leur stockage dans un tiroir (pas d'exposition UV, pas de choc....) n'est pas la cause de tous ces ennuis de début d'année.......

Dimitri   
Revenir en haut
Auteur Message
Publicité






MessagePosté le: 06/01/2012, 17:57    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Auteur Message
thandrieux
DIEU DE LA MAINTENANCE
DIEU DE LA MAINTENANCE

Hors ligne

Inscrit le: 19 Juin 2009
Messages: 364
DIJON Maintenance indépendant Masculin

MessagePosté le: 06/01/2012, 19:43    Sujet du message: Tribulation autour d'un TSX17 Répondre en citant

Bonjour dimdim37,

Comme tu le dit dans ton post il y a 2 types de mémoire : RAM et EPROM.
Pour l'EPROM il faut les effacer avec une lampe UV, par contre la RAM sauvegarde ses données grâce à une pile ou une batterie. Tant que ta mémoire était dans l'automate elle devait être alimentée par celui-ci.
Si tu la sortie pendant 15 jours et que la batterie (de 1993) était faible, malheureusement je pense que le programme s'est évaporé.
J'espère que tu as une sauvegarde au moins "papier" du programme. Après trouver quelqu'un qui a PL7-2 près de chez toi ne devrait pas être trop dur pour recharger le programme.
A+
_________________
Andrieux Diagnostic : Maintenance industrielle, interventions, conseil, formations
Revenir en haut
Visiter le site web du posteur
Auteur Message
dimdim37
NOUVEAU MEMBRE
NOUVEAU MEMBRE

Hors ligne

Inscrit le: 06 Jan 2012
Messages: 2
France Technicien maintenance Masculin

MessagePosté le: 07/01/2012, 12:49    Sujet du message: Tribulation autour d'un TSX17 Répondre en citant

Bonjour, tout d'abord merci pour ta réponse même si elle ne me rassure pas car du coup sa confirme le fait que j'ai pu me mettre dans la m**de tout seul comme un grand, aïe aïe aïe!

Non, plus sérieusement, je pensais réellement que les 2 cartouches amovibles étaient des EPROM. Je croyais aussi que le contenu de ces cartouches étaient recopié dans la RAM de l'automate lors de la mise sous tension si les 2 contenus étaient différents. Donc dans ma tête je pensais que le fait de perdre la RAM interne n'était pas un problème puisque le fait de redémarrer avec les cartouches rétablirai la situation.
Visiblement, j'ai fait une grosse erreur. Au meilleur des cas, je dois re créer le programme et pour sa, il me faut l'application PL7-2 puis le ré-injecter dans l'automate et re-valider la chaîne, tout sa le plus vite possible.
A+
Revenir en haut
Auteur Message
MACHINET
CONNAISSEUR
CONNAISSEUR

Hors ligne

Inscrit le: 29 Sep 2012
Messages: 36
MEAUX Enseignant Masculin

MessagePosté le: 29/09/2012, 21:55    Sujet du message: Tribulation autour d'un TSX17 Répondre en citant

Bonjour, je ne sais pas si le problème avec cet automate est toujours d'actualité mais il se fait que depuis 1 an, je me creuse la tête pour permettre de continuer d'utiliser PL72 sur des nouvelles bécanes et ma solution semblerait pouvoir aussi t'aider pour ton souci. Au passage, j'ai créé une image disquette clef en main, bootable directement et la possibilité de configurer le numéro de port COM sur lequel est branché le TSX17 sur le PC et PL72 se lance : si tu as ta sauvegarde de programme (fichier.bin), tu pourras le recharger avec, sans aucun problème. Merci de me contacter pour obtenir cette image disquette...

Bon courage !
_________________
Pourquoi faire simple quand on peut faire compliqué ? (Jacques Rouxel)
Revenir en haut
MSN
Auteur Message
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 18:33    Sujet du message: Tribulation autour d'un TSX17

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Maintenance Industrielle Index du Forum -> Automatisme -> Télémécanique Toutes les heures sont au format GMT + 2 Heures
Page 1 sur 1
Sauter vers:  
Ouvrir la calculatrice scientifique

Recherche Avancée



Contrat Creative Commons
.
Portail | Index | creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2016 phpBB Group
Traduction par : phpBB-fr.com

mtechnik