Portail · Index · FAQ · Rechercher · Membres · Groupes  · S’enregistrer  · Profil · P.M. · Connexion
Problème connexion API au PC via port usb

 
Poster un nouveau sujet   Répondre au sujet    Maintenance Industrielle Index du Forum -> Automatisme -> Omron
Sujet précédent :: Sujet suivant  

Auteur Message
projet16
NOUVEAU MEMBRE
NOUVEAU MEMBRE

Hors ligne

Inscrit le: 24 Mar 2011
Messages: 3

MessagePosté le: 24/03/2011, 13:39    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Bonjour,

Je fais partie d'un groupe de projet (en deuxième année d'école d'ingénieur) et une partie de notre projet consiste à configurer un automate. Le problème est que je n'arrive pas à passer en online dans cx-programmer (première fois que je l'utilise).
Pour la connexion de l'API à l'ordinateur, j'utilise un câble fourni par OMRON : CS1WCIF31 qui permet de passer d'une connectique RS232C(API) vers une connectique USB(ordinateur). L'API est bien détecté par windows et les pilotes sont installés.
Sous cx-programmer j'ai bien renseigné le type d'api: CJ1M (UC: CPU13) mais pour le type de réseau je ne sais pas ce que je dois mettre.
J'ai laissé toolbus et dans le nom du port j'ai essayé avec les deux qu'on me propose (COM1 et COM3), aucun ne fonctionne.
Comment savoir sur quel port est connecté l'api (j'utilise windows xp)? Est-ce que j'ai manqué une étape dans la configuration? Parmi la suite de logiciel cx-one, est-ce qu'il y a un meilleur logiciel que cx-programmer pour "détecter" l'API?

Merci d'avance.
Revenir en haut
Auteur Message
Publicité






MessagePosté le: 24/03/2011, 13:39    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Auteur Message
mat31
NOUVEAU MEMBRE
NOUVEAU MEMBRE

Hors ligne

Inscrit le: 08 Juil 2010
Messages: 12
TOULOUSE Technicien de maintenance Masculin

MessagePosté le: 25/03/2011, 00:45    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Bonsoir, 


Pour savoir tu passe par quel port de l'automate : le port périphérique ou le port RS232. 
Si tu passes pas le port serie il faut que tu mettes l’interrupteur DIP 5 sur ON. 
Si tu passe par le port périphérique il faut que l’interrupteur DIP 4 soit a OFF (il est par défaut a OFF)
SI jamais tu as besoin de documentation va voir sur ce site http://support-omron.fr/Doc_Api.html


En espérant t'avoir rendu service.
Revenir en haut
Auteur Message
projet16
NOUVEAU MEMBRE
NOUVEAU MEMBRE

Hors ligne

Inscrit le: 24 Mar 2011
Messages: 3

MessagePosté le: 31/03/2011, 14:10    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Bonjour,
Déjà merci de votre réponse,
et désolé de ne pas avoir répondu plus tôt mais je n'ai pas pu tester avant aujourd'hui. Je passe effectivement par le port série (connecté en usb au pc) et l'interrupteur DIP 5 était sur off. Je l'ai donc passé sur ON (tous les autres sont sur OFF) et malheureusement ça n'a pas changé mon problème, je n'arrive toujours pas à passer en online. Qu'est-ce qu'il y a à configurer dans cx-programmer pour pouvoir faire correspondre cette configuration avec celle de l'API? Ce que j'ai fait c'est mettre le type d'API: CJ1M (dans paramètre j'ai sélectionné CPU13 dans type d'UC) et le type de réseau : toolbus (dans les paramètres j'ai mis le port com) (peut-être que je dois prendre autre chose que toolbus?) . Sinon, il y a aussi un port RJ45, faut-il l'utiliser? est-ce que ce serait plus facile à configurer?
Pour le lien que vous avez mis, il est mort.
bonne journée.
Revenir en haut
Auteur Message
projet16
NOUVEAU MEMBRE
NOUVEAU MEMBRE

Hors ligne

Inscrit le: 24 Mar 2011
Messages: 3

MessagePosté le: 31/03/2011, 17:20    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Je fais juste un post pour préciser que j'ai aussi testé en mode online automatique et que ça n'a rien changé, j'obtiens à chaque fois un "echec de la connexion à l'API". Sinon je voulais préciser que sur le câble qui convertit le RS232 en usb, il y a deux LEDs qui sont susceptibles de s'allumer (en fonction du sens dans lequel se fait la conversion de données) et chez moi elle ne s'allume jamais même lors de la tentative de connexion.
Revenir en haut
Auteur Message
RAISIN
CONNAISSEUR
CONNAISSEUR

Hors ligne

Inscrit le: 24 Mai 2011
Messages: 32
saumur automaticien industriel Masculin

MessagePosté le: 15/06/2011, 22:47    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Bonjour essai l'autre protocole
si tu est avec une convertiseur usb/RS232 tu met que tu tes en COM 1 et essai en com auto 
Revenir en haut
Visiter le site web du posteur
Auteur Message
Jean-Christophe
CONNAISSEUR
CONNAISSEUR

Hors ligne

Inscrit le: 12 Jan 2010
Messages: 32
Rosny sous Bois Technical Support Engineer Masculin

MessagePosté le: 24/06/2011, 08:51    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Avec le Swtich 5 a On on force les paramètres par défaut de ce port (Host-Link 7 paire 2 ).

Ce protocole permet la connexion automatique de Cx-Programmer.

LA problématique est surement liée au convertisseur USB/série qui joue sur les niveaux minimum d'une liaison série (donc très peut fiable).

Utilise plutôt une carte PCMCIA qui crée un vrais port série sur ton PC .
Revenir en haut
Auteur Message
DIMIT
CONNAISSEUR
CONNAISSEUR

Hors ligne

Inscrit le: 25 Fév 2011
Messages: 30
TOURS Technicien de maintenance Masculin

MessagePosté le: 17/09/2011, 09:36    Sujet du message: Problème connexion API au PC via port usb Répondre en citant

Bonjour,

Peux tu nous dire qu'elle version de CX PROGRAMMER utilises tu ?
Lors de la connexion en mode on-line on te demande de sélectionner sur quel port tu veux te connecter soit port com soit port USB. As tu bien installer les drivers du câble de connexion qui sont fournis avec ?

Bon courage.
Revenir en haut
Auteur Message
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 00:27    Sujet du message: Problème connexion API au PC via port usb

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Maintenance Industrielle Index du Forum -> Automatisme -> Omron Toutes les heures sont au format GMT + 2 Heures
Page 1 sur 1
Sauter vers:  
Ouvrir la calculatrice scientifique

Recherche Avancée



Contrat Creative Commons
.
Portail | Index | creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2016 phpBB Group
Traduction par : phpBB-fr.com

mtechnik